Requisitos mínimos y recomendados de Overlord: Fellowship of Evil

over5

Recientemente fue anunciado Overlord: Fellowship of Evil el cual tiene un enfoque diferente a las anteriores entregas ya que cuenta con cooperativo para 4 jugadores y una vista isométrica entre lo más destacado. El juego saldrá para  playstation 4, Xbox One y PC donde a continuación podremos ver sus requisitos mínimos y recomendados.

Requisitos Mínimos:

    • Sistema operativo: Windows Vista, Windows 7 o Windows 8
    • Microprocesador: Intel Core 2 Duo E4600 o AMD Athlon x2 5400+
    • RAM: 2 GB
    • Grafica: AMD HD4870 o Nvidia GTX280
    • Espacio en disco: 4 GB

Requisitos Recomendados:

    • Sistema operativo: Windows Vista, Windows 7 o Windows 8
    • Microprocesador: AMD FX Series o Intel Core i5 Series
    • RAM: 4 GB RAM
    • Grafica: AMD R9 270 o Nvidia GTX660
    • Espacio en disco: 4 GB

Hola12312

Jugador de PC, amante de los videojuegos y el fútbol.

Deja una respuesta

Tu dirección de correo electrónico no será publicada.